Unleash the power of 3D
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #14332 Likes: 0
    EmilsVfx
    Participant
    • Posts 67

    I found this bug in BFA 2.94

    Try to optimize some render settings and found this bug.

    at first think it`s depends on the render engine, but no.

    Sampling Tab

    Light Path Tab

    #17563 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Uh, that’s not nice O_O

    Thanks for the report. I will have a look at it tomorrow!

    #17564 Likes: 0
    Reiner
    Participant
    • Posts 4699
    #17570 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Okay, got it back working again. As a quick fix you can replace the ui.py file in the .2.79scriptsaddonscycles path of your Bforartists installation by the one in the zipfile attached here.

    Note that three props are missing now in the Light Paths panel, compared to the Blender 2.7.9 release. But i compare my code with the Blender master. And here those three props are gone. See image.

    A new version may need a few more days. I will first go through the UI again, compare it with the Blender UI, and check if something else is broken. We had already two regressions too much that made it through.

    Kind regards

    Reiner

    #17577 Likes: 0
    EmilsVfx
    Participant
    • Posts 67

    File instal full path:

    C:Program Files (x86)BforartistsBforartists 0.9.4 – 64 BitBforartists_win64_0942.79scriptsaddonscycles

    That is shadow check box ?

    #17578 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Yes. Replace the ui.py here with the one from the attached zipfile.

    That is shadow check box ?

    No. That is without. The shadow checkbox is gone. Don’t ask me why. The Blender devs did it. I just implement their code here.

    I have of course searched if they have placed the feature elsewhere under another name. But without luck. And the prop for the shadow checkbox is gone in the code. So there is nothing that i could do. Since i rely at the Master code, not the Release Version code.

    #17588 Likes: 0
    Draise
    Participant
    • Posts 1181

    So, to turn off shadows it now is only in light settings?

    :dance:

    #17599 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Seems so. As told, i haven’t found another location for it anymore. But imho, this makes much more sense, since shadow is a light setting.

    #17600 Likes: 0
    davis
    Participant
    • Posts 295

    According to the tooltip in Blender this turns on or off wether transparent shadows are calulated or not. – Is it turned on or off by default? Anyway, it would be handy to have as an option.

     

    #17602 Likes: 0
    Reiner
    Participant
    • Posts 4699

    The Blender manual does not apply here anymore, unfortunately. As told, Bforartists relies at the Blender Master. Not the Blender release version. That’s two different branches. The release version has this checkbox. But in the Blender master it’s gone.

    #17649 Likes: 0
    Draise
    Participant
    • Posts 1181

    Um.. this is kind of a big issue. Shouldn’t this also be another BFA release?

    :dance:

    #17650 Likes: 0
    Reiner
    Participant
    • Posts 4699

    We cannot make a single release for every bug, sorry :)

    But yes, 0.9.5 is at its way. But first let’s triple check that we have really catched all showstoppers. I want to start this check since three days now, and there is always something else to do ^^

    #17652 Likes: 0
    Draise
    Participant
    • Posts 1181

    Yeah.. makes sense. Good things take time.

    :dance:

    #17668 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Just wanted to add, Blender Master has two new panels in the object tab now. Motion Blur and Cycles Settings. And in Cylces settings you will find shadow settings now too. And we have it like in Blender master, we have the two new panels already.

    We need to add this to the manual at one point. Creating a task now …

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.