Unleash the power of 3D
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #25950 Likes: 0
    Anonymous

      hello there, just discovering this project.. great job !

      small issue however, I did everything I could (emulate 3 buttons, change some hotkeys etc…saved pref, restart the app) but absolutely nothing let me assign alt + click for the 3d view rotation (usually a lot more convenient for pen / tablets usage than right click)

      did I miss something ? bug ?

      vers 4.0.2

       

      #25951 Likes: 0
      BFA-Reiner
      Keymaster

        Hi maclud,

        Does this work in Blender? And what exactly did you change, and where? And what do you mean with click? Left, right, double, release, click drag? There is more than one option 🙂

        The original rotate 3d view can be found when you search for the rotate hotkey in the keymap manager. See attached image. Did you try to change this entry? There might also be an overriding problem involved. Maybe the key already exists. And we already have four alternative rotate view hotkeys too.

        Kind regards

        Reiner

         

        Attachments:

        This is my signature. You can change your signature in the profile

        #25953 Likes: 0
        Anonymous

          hello again..

          trying just a simple alt + left click (or click and drag sorry), it’s in the title 😉
          yes it works by default in blender when you check “emulate 3 button mouse” in the settings>input>mouse menu
          (it’s also the “default” in c4d I think and… oops nope, my bad, not in 3dsmax)

          yes I already found and tried all those differents hotkey in the keymap manager that you mentioned, and also had checked if the key already existed anywhere else (also just removed/unchecked earlier “every” other hotkeys, not only the 3dview ones, involved with alt just to see if the problem was, as you mentioned, an overriding problem, still no luck, but maybe I missed one somewhere)

          the hotkey alt + left click DOES work as intended however – I just realised – when “emulate 3 button mouse” in the input menu is UNCHECKED. but then people working with pen will have to also rebind the zoom and translate view hotkey on their own. this not a big deal I admit (but usually very frustrating for some students) and clearly not as convenient as just checking “emulate 3 button mouse” (maybe just in case add a little hint about this for common pen users)

          To be clear, every other change of the keys combination for “rotate view” works fine when “emulate the 3 button mouse” is checked : alt + right click, alt + middle click, ctrl + left click etc… but specifically no alt + left click, which is, I think, the default, and the most convenient and fast in sculpt mode (to not interfere with the smoothing / invert brush effects, mapped by default to shift and ctrl)

          I’m not particularly a hotkey junky, but as this is probably one of the most commonly used, and a complete frustrating deal breaker for me… I just wanted to let you know.

          #25954 Likes: 0
          BFA-Reiner
          Keymaster

            Yeah, the Blender keymap manager is a pain, there is little that we can do.

            And thanks for the heads up 🙂

            This is my signature. You can change your signature in the profile

            #25955 Likes: 0
            BFA-Reiner
            Keymaster

              Hmm, finally found a few moments to test this out. And it works just fine here. See attached image.

              Attachments:

              This is my signature. You can change your signature in the profile

              #25957 Likes: 0
              Anonymous

                thank you for your reply and testing it out… might be just a strange behavior on my machine with bforartist (it works fine in blender).

                good luck with the project

                —->I attached a video of the issue just in case (I should have started with this to make it more clear)…

                https://www.veed.io/view/fr-FR/47d45ef2-5de1-4e0b-9184-4f634743563c?panel=

                #25962 Likes: 0
                BFA-Reiner
                Keymaster

                  Many thanks 🙂

                  And thanks for your effort. The video is unfortunately not available though.

                  The last thing that i can think of is that you have customized the keymap and run into a hotkey conflict here. When it works in Blender, then you could test with the Blender keymap as a last idea.

                  It might also be a good idea to join our discord. Here you will get a more immediate reaction. And you can even upload videos up to 10 mb there. https://discord.com/invite/yKuR77v

                  Kind regards

                  Reiner

                  This is my signature. You can change your signature in the profile

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.