Unleash the power of 3D
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #25914 Likes: 0
    digimooses
    Participant

      Happy New Year 2024 from Cold Snow Hell(sinki).

      I was testing a bit BFA 4.0.2. Apple Silicon version after making the xattr -cr for it.
      Cycles GPU render is not working at all. It is working nicely on Blender 4.0.2. Some images attached of the problem.

      #25922 Likes: 0
      BFA-Reiner
      Keymaster

        Many thanks for the report. I’ll make it a task.

        Would you mind to report issues at our tracker? All you need is a github account. I may not check the forum at a daily base, and the tracker is simply the better place for such reports.

        https://github.com/Bforartists/Bforartists/issues

        Kind regards

        Reiner

        This is my signature. You can change your signature in the profile

        #25923 Likes: 0
        BFA-Reiner
        Keymaster

          Done https://github.com/Bforartists/Bforartists/issues/4023

          This is my signature. You can change your signature in the profile

          #25927 Likes: 0
          digimooses
          Participant

            Ok.

             

            I made for myself a Github account. That was a pain in the butt. Not for me. I am just a user.

            I noticed that on BFA Intel version Apple metal works, when running it with M1 Mac Studio, and it renders as fast as in Blender. But I think that I will stick with Blender from now on. I hope you can fix this Apple Metal issue.

            All the best and bye, bye.

            #25931 Likes: 0
            shaley
            Participant

              Hi Digimooses

              Saw your other post as well and sorry for not getting back – in Australia and the whole country (including me) shuts down for the Xmas and the ensuing holiday period.

              Sorry to hear you are still having issues. I don’t know what the cause is but as far as I am aware, you are the only user having issues of this sort. We don’t have anyone else coming forward with issues on the Mac silicon version, so I am assuming it is all working as it should for most people.

              I tested the Cycles render on my M2 studio and it is all working as expected. Having selected Metal in the preferences, and GPU render under the rendering tab, as you have no doubt done, Cycles should work. You may want to check in the Add Ons tab that Cycles is enabled. It should be on by default but worth checking.

              It might still be a permissions issue, I suspect, but that seems particular to your set up for some reason.

              Sorry I can’t be much more help. I too am basically a user, but compile the Mac version code for the developers who are PC based, so the previous suggestions, that don’t work in your case, pretty much exhaust my expertise.

              I hope you find a solution.

              Best

              #25936 Likes: 0
              digimooses
              Participant

                Hi Shaley.

                No problem. Also in Finland many places are closed and on holidays. From next Monday on the situation goes back to normal again here.

                Yes, I agree, the problem could be in my end.ย This permission issue, you mentioned might be true. It also could be some other application I am using, which somehow blocks BFA functionality. But this is just my further guessing based on your thoughts. Finding this kind of possible blocker would be quite a job. At the same time on Blender 3.6.5 and 4.0.2 everything works as they should.

                Althougt M1 Mac Studio Max is not a rocket, if comparing to nVidia RTX cards, Apple Metal performance is quite important for me. According to my tests, it makes my product rendering work significantly faster with the modest 32 GPU cores I have.

                Best to you too.

              Viewing 6 posts - 1 through 6 (of 6 total)
              • You must be logged in to reply to this topic.