Unleash the power of 3D
Viewing 15 posts - 16 through 30 (of 56 total)
  • Author
    Posts
  • #19779 Likes: 0
    Anonymous
    • Posts 2

    Awesome work guys, I was trying to build the linux version also since I notice there wasn’t any linux maintainer no more, but I haven’t compiled a program before and was getting errors, any chance you could teach me linuxdev via Discord or similar?

    #19780 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Not at my end, sorry. Hardcore Windows user here. I am happy when i can start my Ubuntu ^^

    But maybe you can tell us the error that you get :)

    #19836 Likes: 0
    Anonymous
    • Posts 2

    Issues with Open Shading but I am a very very noob when compilign something in Linux, something I wouldn’t mind learning though…..

    #20359 Likes: 0
    linuxdev
    • Posts 25

    I just added the “bforartists2” package to http://linux.developer.free.fr/

    Given its alpha status, bforartists2 may coexist with bforartists (v1).

    So far, I noticed just one (but annoying) problem: it does not seem to recognize my graphics card for “Cycles render devices”, while the card is properly detected and used with v1…

    #20360 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Thanks :)

    So you can’t render? Or does it not keep the setting?

    #20361 Likes: 0
    linuxdev
    • Posts 25

    I can render with the CPU. It’s just that, unlike Bforartists v1, v2 does not “see” (*) the GPU and cannot therefore use it.

    (*) In Edit -> Preferences -> System -> Cycles Render Devices, I got “No compatible GPUs found” for either CUDA or OpenCL.

    #20362 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Thanks for the information. Have you installed Cuda at your system, and enabled Cuda in Cmake before compiling?

    Cuda and quite a few other compiling heavy options are off in the default cmake configuration. Have a look in the build_filescmakeconfig directory for the blender_release.cmake file. There you can read what features are enabled for the release version.

    #20363 Likes: 0
    linuxdev
    • Posts 25

    This is not the problem: no, the CUDA toolkit was not installed (and the corresponding -D option not passed to cmake in my .spec file), but neither was it when I built Bforartists v1, and it yet does not prevent Cycles to detect and use the GPU in the latter, as a CUDA device…

    #20364 Likes: 0
    Reiner
    Participant
    • Posts 4699

    That’s impossible ^^ 

    No Cuda means no GPU rendering with Cuda. Can it be that you mean the OpenCL device instead? This one also renders at the gpu if available. But that’s nothing where i can be of help, sorry. I have a Nvidia card with Cuda. Just curious, does Blender 2.80 work for you with either Cuda or OpenCL?

    #20365 Likes: 0
    linuxdev
    • Posts 25

    Have a look by yourself… Spec (rpm package build script) file, installed rpm, screen shot with settings window and splash screen…

    So, yes, maybe you are right on the fact that the GPU was actually used in OpenCL mode in Bforartists1 despite what it pretends to use (CUDA) in its preferences window, but anyway, Bforartists2 does not recognize my GPU in either of the CUDA or OpenCL modes… That’s a bug, I’m afraid…

    Note that I may be able to install the CUDA 9 toolkit and build Bforatists2 with it, since blender 2.80 might build against it (unlike v2.79, that required CUDA 8, but the latter requiring gcc 5.5… that OSL could not be built with… lol !). Time permitting, I may give it a try (but don’t hold your breath on it: I’m not using Bforartists to render stuff anyway, but only for creating/editing Collada meshes)…

    #20366 Likes: 0
    linuxdev
    • Posts 25

    Blender v2.80 (beta) is indeed seeing the CUDA device but not finding OpenCL while the proprietary NVIDIA driver, with OpenCL libraries, is installed on my system…

    #20367 Likes: 0
    Reiner
    Participant
    • Posts 4699

    The comment is funny. Bforartists 1 for Windows compiled in fact just fine with Cuda 9 and 10. Yes, we are at Cuda 10 already ^^

    It is linux, i am lost, sorry. It can be everything :)

    #20393 Likes: 0
    linuxdev
    • Posts 25

    I uploaded the RPM packages for Bforartists 2 alpha 2 on my site.

    Note to developers: I had to re-add files (from alpha 1 sources) that are missing from alpha 2 sources and cause a build failure: they are *.dat files in release/datafiles/blender_icons16 and release/datafiles/blender_icons32, that cause, when missing, a failure to build the png icons.

    #20394 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Huh? There shouldn’t be missing anything. O_O

    Could be a linux specific problem, which i cannot even reproduce then. Anyways, thanks for your effort :)

    #20418 Likes: 0
    linuxdev
    • Posts 25

     
    Greetings,

    I uploaded the RPM packages for Bforartists 2 alpha 3 on my site.

    Note to developers: I *still* had to re-add files (from alpha 1 sources) that are missing from alpha 2 sources and cause a build failure: they are *.dat files in release/datafiles/blender_icons16 and release/datafiles/blender_icons32, that cause, when missing, a failure to build the png icons.

    cmake error sample:

    make[2]: *** No rule to make target '../release/datafiles/blender_icons16/icon16_decorate_library_override.dat', needed by 'release/datafiles/blender_icons16.png'. Stop.

     
    Also, and while built in the same way and on the same build system as bforartists 1, the resulting binary is still unable to detect my GPU with bforartists 2 while it is properly detected as a CUDA device with bforartists 1 and blender v2.80… If you made any change to the GPU code when compared to blender’s, I’d recommend that you look into the corresponding commits because something got apparently (or rather, obviously) broken there…

Viewing 15 posts - 16 through 30 (of 56 total)
  • You must be logged in to reply to this topic.