Unleash the power of 3D
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #14644 Likes: 0
    Nemo
    Participant
    • Posts 7

    I’m having trouble where Add New Library and Add To Library don’t seem to be working for me.

    I’d like to save some custom materials but this is making things a bit harder.

    #20771 Likes: 0
    Draise
    Participant
    • Posts 1181

    Is this in the VX material library addon?

     

    :dance:

    #20772 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Hey Nemo,

    That’s the only way to save a material, so i guess he means the addon. Works like charm here. Have you saved the scene before inserting the new material? 

    #20773 Likes: 0
    Nemo
    Participant
    • Posts 7

    Yes, the VX Library addon. It didn’t work until I launched the program as an Administrator and then I could create a new Library and add stuff. Although it does seem to only save materials when in Administrator mode. If not I get either an error message or the new material just doesn’t get saved.

     

     

    #20774 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Thanks for the feedback. The addon should definitely not require admin rights. And here it works just fine. So there is currently little that we can do :/

    Could you please check if it works in Blender? It’s an official Blender addon. But you have to turn it on in Blender first. We have it activated by default.

    #20775 Likes: 0
    Nemo
    Participant
    • Posts 7

    I did get another possibly related error when browsing the Addons in the settings menu where lots of addons appear to be duplicated and causing conflicts. (I haven’t installed any additional addons btw)

    I don’t have regular Blender installed at the moment but I can download an check.

     

    Luckily the material library does seem to be saving materials now (although I still have to be in admin mode).

    #20776 Likes: 0
    Reiner
    Participant
    • Posts 4699

    :/

    Is there an error message in the console?

    #20777 Likes: 0
    Draise
    Participant
    • Posts 1181

    If you are using 0.7.0 you will see some contribution add-ons are duplicated. Also sometimes, if you overwrite an installation you’ll get doubled up add-ons.

    I keep forgetting to report this!

    Where is your installation? The system drive may need read/write privalages to work.  

    If you install to another location,  does the error still happen?

    :dance:

    #20779 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Never noticed this one O_O

    Please make a bug report :)

    On the other hand, you say this was version 0.7.0? Does this problem still exist in 0.8.0?

    But yes. Over installation can cause double addons. In this case you should remove the old installation first, then reinstall the new version. When you have installed addons externally then it’s also a good idea to remove the bforartists folder in the appdata directory. That’s at windows C:UsersYOURUSERNAMEAppDataRoaming . This folder contains also all the other modificated settings. So when you want a clean install, then away with the bforartists folder.

     

    #20780 Likes: 0
    Nemo
    Participant
    • Posts 7

    Yeah I was still on 0.7.0. Installed 0.8.0 earlier today and while that did fix the duplicate addons it didn’t fix the need for admin priviliges. Same issue in regular Blender 2.8 with the addon enabled. Probably my Windows 10 just not trusting Blender… I have it set up to just run Bfa with admin priviliges on launch so that solves that problem.

    #20783 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Thanks Nemo :)

    Hm, seems to be normal behaviour when even Blender acts this way. The odd part is, i never noticed it ^^

     

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.