Unleash the power of 3D
#25953 Likes: 0
Anonymous

    hello again..

    trying just a simple alt + left click (or click and drag sorry), it’s in the title 😉
    yes it works by default in blender when you check “emulate 3 button mouse” in the settings>input>mouse menu
    (it’s also the “default” in c4d I think and… oops nope, my bad, not in 3dsmax)

    yes I already found and tried all those differents hotkey in the keymap manager that you mentioned, and also had checked if the key already existed anywhere else (also just removed/unchecked earlier “every” other hotkeys, not only the 3dview ones, involved with alt just to see if the problem was, as you mentioned, an overriding problem, still no luck, but maybe I missed one somewhere)

    the hotkey alt + left click DOES work as intended however – I just realised – when “emulate 3 button mouse” in the input menu is UNCHECKED. but then people working with pen will have to also rebind the zoom and translate view hotkey on their own. this not a big deal I admit (but usually very frustrating for some students) and clearly not as convenient as just checking “emulate 3 button mouse” (maybe just in case add a little hint about this for common pen users)

    To be clear, every other change of the keys combination for “rotate view” works fine when “emulate the 3 button mouse” is checked : alt + right click, alt + middle click, ctrl + left click etc… but specifically no alt + left click, which is, I think, the default, and the most convenient and fast in sculpt mode (to not interfere with the smoothing / invert brush effects, mapped by default to shift and ctrl)

    I’m not particularly a hotkey junky, but as this is probably one of the most commonly used, and a complete frustrating deal breaker for me… I just wanted to let you know.