Unleash the power of 3D
#21878 Likes: 0
BFA-Reiner
Keymaster
  • Posts 609

Ah, you are at Linux or Mac. There the hotkey F2 does nothing. Under Windows there is an extra console window that you can call.

AL lib: (EE) GetLoadedHrtf: Invalid header in /usr/share/openal/hrtf/default-44100.mhr: “MinPHR02”
AL lib: (EE) GetLoadedHrtf: Failed to load /usr/share/openal/hrtf/default-44100.mhr

Thanks for this message. This is fortunately just the default warning about audio. And not of interest. It just means that something else is used then. When there is no other error then we don’t have a problem. And i can see from your shot that now the menu is showing. Initially i thought that this is your problem, that the add menu does not show. But it seems all well.

Now for your problem, and the third time: you are in SHADER EDITOR. The viewer node is a node for COMPOSITING. It is not available in the Shader Editor. Only in the Compositor editor (and the Texture Node editor. But this one is under overhaul at the moment). Sorry for the big letters here, it is just meant to make the important bit clear since i already told it twice before. You are in the wrong node editor 🙂

The viewer node is meant to display the render result for compositing in the background of the node editor. The shader editor is to edit materias. That’s a completely different tool and purpose. And does not support such a feature.

To find the Viewer node:

Switch to Compositing layout.

Turn on Use Nodes to make the menu items clickable.

Now have a look at the Add menu again.

I hope this fixes your problem now 😉

Kind regards

Reiner

This is my signature. You can change your signature in the profile