Unleash the power of 3D
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #22504 Likes: 0
    kurtf
    Participant
    • Posts 4

    Hello,

    new user here. I’ve been trying to come to grips with Blender 2.8 (and .9) and thought perhaps BforArtists might be the right choice for me.

    I’ve downloaded the .deb package for Linux but the executable won’t launch. I’m on Elementary OS vs. 5.1.7 (an off shoot of Ubuntu). I keep getting a terminal error-

    /opt/bforartists/bforartists: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28′ not found (required by /opt/bforartists/bforartists)
    /opt/bforartists/bforartists: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29′ not found (required by /opt/bforartists/bforartists)

    which seems to be about a missing file for 64 bit linux. Any hints to install the missing pieces?

    Thanks,

    -Kurt

    #22505 Likes: 0
    BFA-Reiner
    Keymaster
    • Posts 613

    Hi Kurt,

    Sorry for your troble. Our linux specialist is currently having a look at it. But the short story from what i was told is, your kernel is too old. And you cannot easily update LibC, which is part of the kernel ( i hope i have understood this part right ^^) . So i would suggest to update your Elementary OS.

    Kind regards

    Reiner

    This is my signature. You can change your signature in the profile

    #22508 Likes: 0
    kurtf
    Participant
    • Posts 4

    Understood. Too bad about the kernel.

    Elementary is based on Ubuntu 18.04 Long Term Stable Release, which is of course older than the most recent, cutting edge Ubuntu. I understand the next version of Elementary will be based on Ubuntu 20.04 LTS.

    I should be able to check BforArtists then.

    Thanks.

    #22509 Likes: 0
    BFA-Reiner
    Keymaster
    • Posts 613

    Ubuntu 18.04 is indeed already outdated. That’s unfortunately the way it is with Linux, sorry 🙂

    This is my signature. You can change your signature in the profile

    #23242 Likes: 0
    garagebay9
    Participant
    • Posts 5

    I’m having the same issue on a completely updated Debian 10 install (the current stable release, which Ubuntu is built on) with  2.8.0, and I ran into it with 2.7.0 as well.

    It looks like what is happening is that with Ubuntu’s frequent release schedule, it picks up new versions of glibc from the core linux development branches much more often than any other distro.  That means the version of glibc that bForArtists gets compiled against in Ubuntu is far enough ahead of other distros that pretty much no other distro will have it.  Since it’s not a library that can be swapped out or upgraded easily, we can’t easily apt-get our way around this one, and it sounds like compiling locally has other big drawbacks.

    I can understand not supporting every distro out there (there’s hundreds), but it seems like a more accurate way to label the Linux release is that it’s (basically) really only supported on Ubuntu.

    Are there other solutions to this?  I made a clean break with Windows and 3dsmax to switch over to the blender ecosystem, and this is a major roadblock. :unsure:

    #23254 Likes: 0
    MoxFulder
    Keymaster
    • Posts 23

    Am I correct with the assumption that Debian 10 has the glibc version 2.28?
    You can check and verify that by running: ldd –version

    As another note: There are other linux distributions which are ahead of Ubuntu (where groovy seems to provide 2.32 but Arch-based distributions are already using 2.33). But I see the point of being more current than many other distributions.

    #23255 Likes: 0
    BFA-Reiner
    Keymaster
    • Posts 613

    Hi garagebay,

    I feel your frustration, i share it. But there is currently no solution to this dilemma. We have unfortunately just limited resources, and i have unfortunately upgraded to Ubuntu 20.10 already. A step back is not possible anymore. And we have to make a cut somewhere with our limited resources.

    The only thing that you could do is to compile Bforartists by yourself. This isn’t even this hard, it should work flawless and in the same way than for Blender on most Linux distributions. Clone the repository, then run make, and along the way you might need to install some missing dependencies. But for full benefit you would need to compile at least with Nvidia’s Cuda, which is another challenging task on some distributions.

    Kind regards

    Reiner

     

     

    This is my signature. You can change your signature in the profile

    #23261 Likes: 0
    BFA-Reiner
    Keymaster
    • Posts 613

    garagebay, could you please be so kind and have a look if this version here fixes the problem?

    Linux Ubuntu, possible fix for the glibc problem https://www.bforartists.de/data/dev/ubuntudevbuild-10-03-2021.tar.xz – 171 Mb

    This is my signature. You can change your signature in the profile

    #23262 Likes: 0
    garagebay9
    Participant
    • Posts 5

    MoxFulder – yes, Debian 10 latest is using glibc 2.28.  I doubt that will change until either very late in the Debian 10 (stretch) development cycle, or Debian 11.\

    Reiner – I completely understand the limited development and support resources.  I’m also not against trying to compile bFA locally, my only hesitation is that you mentioned here and in another thread that some parts (Cuda and Optix) are more complicated to build locally, and I haven’t found documentation on the process to build with those.

    For the .tar you linked, is that intended to entirely replace glibc 2.28 in the Debian environment?  I’m still pretty new to Linux and I’m not entirely sure what I need to do with that or how.

    #23263 Likes: 0
    BFA-Reiner
    Keymaster
    • Posts 613

    No, the glibc version is now statically compiled into Bforartists directly. MoxFulder found a way to do so. It should now work for you. And it will not harm your system. Could you please test if it works as thought?

    This is my signature. You can change your signature in the profile

    #23264 Likes: 0
    garagebay9
    Participant
    • Posts 5

    I extracted the contents to /home/bforartists/, then tried $ ./bforartists, I still received this error:

    ./bforartists: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.32′ not found (required by ./bforartists)
    ./bforartists: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29′ not found (required by ./bforartists)

    If I did something incorrectly I’m happy to retry.

    #23265 Likes: 0
    BFA-Reiner
    Keymaster
    • Posts 613

    Ah, too bad, so the workaround did not work around the problem.

    Well, we tried. I personally run out of ideas now. So i fear it remains as it is. The only option that you have is as told to compile Bforartists by yourself then.

    Thanks for testing. And sorry that i don’t have better news.

    This is my signature. You can change your signature in the profile

    #23342 Likes: 0
    garagebay9
    Participant
    • Posts 5

    I’ve succeeded (sort of) by dropping back to 2.2.0, which runs successfully on Debian 10.  It’s not the latest and greatest, but I’ve been using 3dsmax 2016 for 5 years, so… I can live with only 9 months behind the release curve. 🙂

    #23345 Likes: 0
    BFA-Reiner
    Keymaster
    • Posts 613

    I knew i had overlooked something!

    We have meanwhile some experimental builds up in the developer section. Compiled in a special docker environment at CentOS. This version needs a much lower glibc version. And should work at your system.

    Go to the developer section, and download the centos developer version.

    https://www.bforartists.de/download/

    The deb version has an issue that it doesn’t show the starter icon at every linux distribution. At Ubuntu it doesn’t. But there is also the tar.xz version.

    Hope this helps 🙂

    This is my signature. You can change your signature in the profile

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.