Unleash the power of 3D
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #14256 Likes: 0
    Kot
    Participant
    • Posts 9

    How can I get rid of this strange effect (is it called ‘clipping’?) and make my whole model visible?

    #16931 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Hey, Kot, would you be so kind not to post everything in one thread? Thanks. I’ve splitted the thread into its own now. :)

    Which has unfortunately killed the image … :/

    To answer your question, have you accidentally activated Clipping Border? If so, then click this item again, and the clipping should be removed.

     

    #16932 Likes: 0
    Kot
    Participant
    • Posts 9

    No, it’s not that :( This model is made of dozens of small objects and clipping affects all the objects

    https://youtu.be/_-0Pye4kU2U

    #16933 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Interesting. Hm, you have hidden the ground grid. So i cannot see how the scale of the object is. How big are the objects? Have you zoomed in too strong? Have you accidentally changed the clipping values in the properties sidebar? What happens when you reset the 3D view?

    Is it possible to get this blend file? When it’s below 10 Mb then you could zip it and attach it here.

    #16934 Likes: 0
    Kot
    Participant
    • Posts 9

    I haven’t hidden the ground grid, it just may not be well visible (you can see it in the new film ;) ). The model is quite big, I had to enlarge it because when I exported it to .obj file and tried to use in a game prototype, it was too small and collision detection didn’t let camera to move (I checked with Irrlicht/FreeBasic and AppGameKit).

    Zooming in and out doesn’t show more of the clipped building (as you can see here: https://youtu.be/pglLjxEXxUQ ) and AFAIR there wasn’t such effect in 0.91 version.

    I hope it helps.

    #16936 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Have it. And it’s the same behaviour in Blender and also Bforartists 0.9.1 :)

    Can it be that you have Load UI ticked? Blender shows the clipping. Bforartists not. That’s why the screenshot is made in Blender.

    The cause is, your models are quite large. The clipping range in the 3d view for the world camera goes from 0.1 to 1000. Your models are outside of this range. You somehow managed to navigate the world camera into a corner here. And so just a part of your scene can be displayed. Increase the maximum clipping to let’s say 2000. Then your full scene shows again.

    Second alternative: turn off Load UI in the user preferences.

    The third alternative is to scale down the models in the scene so that they fit into the 0.1 to 1000 clipping range.

    I would do all of it ^^

    Hope that helps :)

    #16937 Likes: 0
    Kot
    Participant
    • Posts 9

    Thanks, everything is OK now :)

    #16941 Likes: 0
    Reiner
    Participant
    • Posts 4699

    Yay o/

    #16950 Likes: 0
    Draise
    Participant
    • Posts 1185

    Clipping can also be set in the camera tab when you have it selected.

    :dance:

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.