Unleash the power of 3D
#20421 Likes: 0
linuxdev
  • Posts 25

 
Yes, I have the following Cycles-related options in the cmake command line:

-DWITH_CUDA_DYNLOAD=ON -DWITH_CYCLES=ON -DWITH_CYCLES_OSL=ON -DWITH_CYCLES_DEVICE_CUDA=ON -DWITH_CYCLES_DEVICE_OPENCL=ON

 
I also do observe that the nvidia-uvm module gets loaded as soon as I select CUDA in the “Cycles render devices” radio-buttons of the Preferences panel in bforartists2 (and 1, and blender), even without the fake nvcc trick. So, it does seem to dynamically load CUDA.
 
Note however that the fake nvcc trick is still insufficient for rendering with the GPU (bforartists2 complains it cannot get the nvcc version, which is normal since it’s just /bin/true that is actually executed) which, again, does not happen with v1 or blender.
So, I also ‘grep’ped the sources for “nvcc” and found an option that might have explained it and I recompiled, adding -DWITH_CYCLES_CUBIN_COMPILER=ON, but to no avail (it does not change anything at all)…