Unleash the power of 3D
#20419 Likes: 0
  • Posts 25

Following my last message, I tried something: I ran bforartsist2 from the command line, so to see any warning printed to the stderr output, and it did pay !

When opening the Preferences panel, I get:

which: no nvcc in (/usr/local/bin:/usr/local/sbin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/games:/usr/games)

Meaning bforartsist2 is searching for the NVIDIA CUDA compiler and, not finding it (which is normal, since I don’t have the CUDA toolkit installed), prints an empty list of CUDA devices in the Preferences panel… This does not happen with either blender v2.80 or bforartsist1.

So, I created a fake nvcc (I created a /usr/local/bin/nvcc link to /bin/true), and, miracle, bforartsist2’s Preferences panel now does find my graphics card, as well as my CPU (it did not even find the latter with nvcc missing while it’s not related in any way with it !)…

So there. Something went amiss in the Preferences panel UI code, that causes this useless check (since Cycles can still use CUDA devices without the help of the CUDA nvcc compiler anyway)…