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User Preferences
This chapter explains how to change Blender’s default configuration with the User Preferences editor.
The Blender User Preferences editor contains settings to control how Blender behaves.

Open User Preferences
To open the User Preferences editor go to File ‣ User Preferences.

Configure
Now that you have opened the User Preferences editor, you can configure Blender to your liking. At the top of
the editor, the available options are grouped into seven tabs:
Interface
Change how UI elements are displayed and how they react.
Editing
2
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Control how several tools will interact with your input.
Input
Customize how Blender reacts to the mouse and keyboard as well as define your own keymap.
Add-ons
Manage Blender’s Add-ons, allowing you to access features not built-in as well as install new features.
Themes
Customize interface appearance and colors.
File
Configure auto-save preferences and set default file paths for blend-files, rendered images, and more.
System
Set resolution, scripting console preferences, sound, graphics cards, and internationalization.

Save the new preferences
Once you have set your preferences, you will need to manually save them, otherwise the new configuration will
be lost after a restart. Blender saves its preferences to userpref.blend in your user folder (see next section,
“Load Factory Settings”, for details).
In the User Preferences editor, click on the Save User Settings button in the bottom left. This will save all of the
new preferences.

Load Factory Settings
Go to File ‣ Load Factory Settings then save the preferences via the User Preferences editor.
Hint
It can be valuable to make a backup of your preferences in the event that you lose your configuration.
See the directory layout section to see where your preferences are stored.

Startup File
Reference
Mode: All modes
Menu: File ‣ Save Startup File
When you start Blender or start a new project with the menu entry File ‣ New, a new scene is created from the
default scene included with Blender.
This default scene can instead be your own customized setup.
To change the default scene, make all of the desired changes to the current scene or current file and File ‣
Save Startup File.

Interface
Interface configuration lets you change how UI elements are displayed and how they react.
3
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Display
Tooltips
When enabled, a tooltip will appear when your mouse pointer is over a control. This tip explains the
function of what is under the pointer, gives the associated hotkey (if any) and the Python function that
refers to it.
Python Tooltips
Displays a property’s Python information below the tooltip.
Object Info
Display the active Object name and frame number at the bottom left of the 3D View.
Large Cursors
Use large mouse cursors when available.
View Name
Display the name and type of the current view in the top left corner of the 3D View. For example: User
Persp or Top Ortho.
Playback FPS
Show the frames per second screen refresh rate while an animation is played back. It appears in the
viewport corner, displaying red if the frame rate set cannot be reached.
Global Scene
Forces the current scene to be displayed in all screens (a project can consist of more than one scene).
Object Origin Size
Diameter of 3D Object centers in the view port (value in pixels from 4 to 10).
Display Mini Axis
Show the mini axis at the bottom left of the viewport.
Size
Size of the mini axis.
Brightness
Adjust brightness of the mini axis.
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Warnings
Prompt Quit
When exiting Blender, a pop-up will ask you weather or not you really want to quit (currently only
available on MS-Windows).

View Manipulation
Cursor Depth
Use the depth under the mouse when placing the cursor.
Auto Depth
Use the depth under the mouse to improve view pan, rotate, zoom functionality. Useful in combination
with Zoom To Mouse Position.
Zoom to Mouse Position
When enabled, the mouse pointer position becomes the focus point of zooming instead of the 2D window
center. Helpful to avoid panning if you are frequently zooming in and out.
Rotate Around Selection
The selected object becomes the rotation center of the viewport. When there is no selection the last
selection will be used.
Hint
This may seem ideal behavior, however, it can become problematic with larger objects such as a
terrain-mesh, where the center is not necessarily your point of interest.

Global Pivot
Lock the same rotation/scaling pivot in all 3D Views.
Camera Parent Lock
When the camera is locked to the view and in fly mode, transform the parent rather than the camera.
Auto Perspective
Automatically to perspective Top/Side/Front view after using User Orthographic. When disabled,
Top/Side/Front views will retain Orthographic or Perspective view (whichever was active at the time of
switching to that view).
Smooth View
Length of time the animation takes when changing the view with the numpad (Top/Side/Front/Camera...).
Reduce to zero to remove the animation.
Rotation Angle
Rotation step size in degrees, when Numpad4, Numpad6, Numpad8, or Numpad2 are used to rotate the
3D View.

2D Viewports
Minimum Grid Spacing
The minimum number of pixels between grid lines in a 2D (i.e. top orthographic) viewport.
TimeCode Style
Format of Time Codes displayed when not displaying timing in terms of frames. The format uses ‘+’ as
5
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separator for sub-second frame numbers, with left and right truncation of the timecode as necessary.
Zoom To Frame Type
How zooming to frame focuses around current frame.
Keep Range:
Seconds:
Keyframes:

Todo.
Todo.
Todo.

Manipulator
Turns manipulators on and off.
Size
Diameter of the manipulator.
Handle Size
Size of manipulator handles, as a percentage of the manipulator radius (size/ 2).
Hotspot
Hotspot size (in pixels) for clicking the manipulator handles.

Menus
Open on Mouse Over
Select this to have the menu open by placing the mouse pointer over the entry instead of clicking on it.
Menu Open Delay
Time for the menu to open.
Top Level
Time delay in 1/10 second before a menu opens (Open on Mouse Over needs to be enabled).
Sub Level
Same as above for sub menus (for example: File ‣ Open Recent).

Pie Menus
Animation Timeout
Length of animation when opening Pie Menus.
Recenter Timeout
The window system tries to keep the pie menu within the window borders. Pie menus will use the initial
mouse position as center for this amount of time, measured in 1/100ths of a second. This allows for fast
dragged selections.
Radius
Size of the Pie Menu.
Threshold
Distance from center before a selection can be made.
Confirm Threshold
Distance threshold after which selection is made (zero disables).

Splash
Show Splash
Display the Splash Screen when starting Blender.
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Editing
These preferences control how several tools will interact with your input.

Link Materials To

Example for a Mesh.
To understand this option properly, you need to understand how Blender works with Objects. Almost
everything in Blender is organized in a hierarchy of data-blocks. A data-block can be thought of as containers
for certain pieces of information. For example, the Object data-block contains information about the Object’s
location while the Object Data ObData data-block contains information about the mesh.
A material may be linked in two different ways:

A material linked to ObData (left) and Object (right).
ObData
Any created material will be created as part of the ObData data-block.
Object
Any created material will be created as part of the Object data-block.
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New objects
Enter Edit Mode
If selected, Edit Mode is automatically activated when you create a new object.
Align To
World
New objects align with world coordinates.
View
New object align with view coordinates.

Undo
Global Undo
This enables Blender to save actions done when you are not in Edit Mode. For example, duplicating
Objects, changing panel settings or switching between modes.
Warning
While disabling this option does save memory, it stops the redo panel from functioning, also preventing
tool options from being changed in some cases.
For typical usage, its best to keep this enabled.

Step
Number of Undo steps available.
Memory Limit
Maximum memory usage in Mb (0 is unlimited).

Grease Pencil
Grease Pencil permits you to draw in the 3D View with a pencil-like tool.
Manhattan Distance
The minimum number of pixels the mouse has to move horizontally or vertically before the movement is
recorded.
Euclidian Distance
The minimum distance that mouse has to travel before movement is recorded.
Eraser Radius
The size of the eraser used with the grease pencil.
Smooth Stroke
Smooths the pencil stroke after it is finished.

Playback
Allow Negative Frame
Time Cursor can be set to negative frames with mouse or keyboard. When using Use Preview Range, this
also allows playback.
8
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Keyframing
In many situations, animation is controlled by keyframes. The state of a value (e.g. location) is recorded in a
keyframe and the animation between two keyframes is interpolated by Blender.
Visual Keying
When an object is using constraints, the objects property value doesnt actually change. Visual Keying will
add keyframes to the object property, with a value based on the visual transformation from the constraint.
Only Insert Needed
This will only insert keyframes if the value of the propery is different.
Auto Keyframing
Enables Auto Keyframe by default for new scenes.
Show Auto Keying Warning
Displays a warning at the top right of the 3D View, when moving objects, if Auto Keyframe is on.
Only Insert Available
This will only add keyframes to channel F-Curves that already exist.

New F-Curve Defaults
Interpolation
This controls how the state between two keyframes is computed. Default interpolation for
new keyframes is Bézier which provides smooth acceleration and de-acceleration whereas
Linear or Constant is more abrupt.
XYZ to RGB
Color for X, Y or Z animation curves (location, scale or rotation) are the same as the color for
the X, Y and Z axis.

Transform
Release confirm
Dragging LMB on an object will move it. To confirm this (and other) transforms, a LMB is necessary by
default. When this option is activated, the release of LMB acts as confirmation of the transform.

Sculpt Overlay Color
This color button allows the user to define a color to be used in the inner part of the brushes circle when in
sculpt mode, and it is placed as an overlay to the brush, representing the focal point of the brush influence. The
overlay color is visible only when the overlay visibility is selected (clicking at the eye to set its visibility), and
the transparency of the overlay is controlled by the alpha slider located at the brush pop-up, located at the top of
the tool shelf, when in sculpt mode.

Duplicate Data
The ‘Duplicate Data’ check-boxes define what data is copied with a duplicated Object and what data remains
linked. Any boxes that are checked will have their data copied along with the duplication of the Object. Any
boxes that are not checked will instead have their data linked from the source Object that was duplicated.
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For example, if you have Mesh checked, then a full copy of the mesh data is created with the new Object, and
each mesh will behave independently of the duplicate. If you leave the mesh box unchecked then when you
change the mesh of one object, the change will be mirrored in the duplicate Object.
The same rules apply to each of the check-boxes in the ‘Duplicate Data’ list.

Input
In the Input preferences, you can customize how Blender reacts to the mouse and keyboard as well as define
your own keymap.

Presets
Blender lets you define multiple Preset input configurations. Instead of deleting the default keymap to create
yours, you can just add new Presets for both the mouse and keyboard. Mouse options can be found on the lefthand side of the editor and keyboard options to the right in the above picture.

Adding and deleting presets

Before changing anything in the default configuration, click on the “plus” symbol shown in the picture to add a
new Preset. Blender will ask you to name your new preset after which you can select the Preset from the list to
edit it. If you want to delete your Preset, select it from the list and then click the “minus” symbol.

Selecting presets
You can change the preset you are using by doing one of the following:
10
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• Selecting the configuration from the Interaction menu of the splash screen at startup or by selecting
Help ‣ Splash Screen.
• Selecting the configuration from the User Preferences Input tab.

Hint
Note that either of the above options will only change the preset for the current file. If you select File ‣ New
or File ‣ Open, the default preset will be re-loaded.

Setting presets to default

Once you have configured your mouse and keyboard Presets, you can make this the default configuration by:
• Opening the User Preferences Input editor and select your presets from the preset list or,
• Selecting your preset configuration from the splash screen.
• Saving your configuration using the Save As Default option from a User Preferences editor

Export/Import key configuration
In some cases, you may need to save your configuration in an external file (e.g. if you need to install a new
system or share your keymap configuration with the community). Simply LMB Export Key Configuration on the
Input tab header and a file browser will open so that you can choose where to store the configuration. The
Import Key Configuration button installs a keymap configuration that is on your computer but not in Blender.
The exported keymap will only contain keymaps and categories that have been modified by the user. In
addition, add-ons may register keymaps to their respective functions, however, these keymaps are not exported
unless changed by the user. This exported file may be thought of as a “keymap delta” instead of a full keymap
export.

Mouse
Emulate 3 Button Mouse
Blender can be configured to work with pointing devices which do not have a middle-mouse button (such
as a two-button mouse, Apple single-button mouse, or laptop touch-pad). The functionality of the three
mouse buttons will then be emulated with key/mouse button combinations as shown in the table below.
Shortcuts for supported mouse hardware¶
3-button Mouse
LMB
MMB

2-button Mouse
LMB
Alt-LMB
11
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3-button Mouse

2-button Mouse

Apple Mouse
mouse button)
RMB
RMB
Cmd-LMB (Command/Apple key
+ mouse button)
Mouse/Keyboard combinations referenced in this manual can be expressed with the combinations shown
in the table. For example:
• MMB drag becomes Alt-LMB drag.
• Shift-Alt-RMB becomes Shift-Alt-Cmd-LMB on a single-button mouse.
Continuous Grab
This feature is used to prevent the problem where an action such as grabbing or panning a view, is limited
by your screen bounds.
This is done by warping the mouse within the view.
Bemerkung
Cursor warping is only supported by relative input devices (mouse, trackball, trackpad).
Graphics tablets, however, typically use absolute positioning, this feature is disabled when a tablet is
being used
This is detected for each action, so the presence of a tablet will not disable Continuous Grab for mouse
cursor input.
Drag Threshold
The number of pixels that a User Interface element has to be moved before it is recognized by Blender.
Select with
You can choose which button is used for selection (the other one is used to place the 3D cursor).
Double Click
The time for a double click (in ms).
Hint
The Mouse emulate option is only available if Select With is set to Right.

Numpad Emulation
The Numpad keys are used quite often in Blender and are not the same keys as the regular number keys. If you
have a keyboard without a Numpad (e.g. on a laptop), you can tell Blender to treat the standard number keys as
Numpad keys. Just check Emulate Numpad.

View Manipulation
Orbit Style

12

Bforartists Reference Manual - © Copyright - This page is under OCL license

Select how Blender works when you rotate the 3D View by default when holding MMB.
Turntable
Rotates the view keeping the horizon horizontal.
This behaves like a potter’s wheel or record player where you have two axes of rotation available,
and the world seems to have a better definition of what is “Up” and “Down” in it.
The drawback to using the Turntable style is that you lose some flexibility when working with your
objects. However, you gain the sense of “Up” and “Down” which can help if you are feeling
disoriented.
Orbit
Is less restrictive, allowing any orientation.
Zoom Style
Choose your preferred style of zooming in and out with Ctrl-MMB
Scale
Scale zooming depends on where you first click in the view. To zoom out, hold Ctrl-MMB while
dragging from the edge of the screen towards the center. To zoom in, hold Ctrl-MMB while
dragging from the center of the screen towards the edge.
Continue
The Continue zooming option allows you to control the speed (and not the value) of zooming by
moving away from the initial click point with Ctrl-MMB. Moving up from the initial click-point or
to the right will zoom out, moving down or to the left will zoom in. The further away you move, the
faster the zoom movement will be. The directions can be altered by the Vertical and Horizontal
radio buttons and the Invert Zoom Direction option.
Dolly
Dolly zooming works similarly to Continue zooming except that zoom speed is constant.
Vertical
Moving up zooms out and moving down zooms in.
Horizontal
Moving left zooms in and moving right zooms out.
Invert Zoom Direction
Inverts the Zoom direction for Dolly and Continue zooming.
Invert Wheel Zoom Direction
Inverts the direction of the mouse wheel zoom.
NDOF device
Set the sensitivity of a 3D mouse.

13

Bforartists Reference Manual - © Copyright - This page is under OCL license

Keymap Editor

The Keymap editor lets you change the default Hotkeys. You can change keymaps for each of Blender’s editors.
• Select the keymap you want to change and click on the white arrows to open up the keymap tree.
• Select which Input will control the function
• Keyboard: Only hotkey or combo hotkey E, Shift-E.
• Mouse: Left/middle/right click. Can be combined with Alt, Shift, Ctrl, Cmd.
• Tweak: Click and drag. Can also be combined with the four previous keys.
• Text input: Use this function by entering a text
• Timer: Used to control actions based on a time period. e.g. By default, Animation Step uses
Timer 0, Smooth view uses Timer 1.
• Change hotkeys as you want. Just click on the shortcut input and enter the new shortcut.
If you want to restore the default settings for a keymap, just click on the Restore button at the top right of this
keymap.

Add-ons
The Add-ons tab lets you manage secondary options which are not enabled in Blender by default. New features
may be added with Install Add-ons. There will be a growing number of such Add-ons, generated by the
Blender-community so look out for that one feature you were missing (or maybe simply create it yourself).
See the Add-ons Page for more on using Add-ons.
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Themes
The Themes tab allows you to customize interface appearance and colors.

The colors for each editor can be set separately by simply select the editor you wish to change in the multi15
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choice list at the left, and adjust colors as required. Notice that changes appear in real-time on your screen. In
addition, details such as the dot size in the 3D View or the Graph Editor can also be changed.
Themes use Blender’s preset system. To save a theme, click the + button next to the preset selection drop-down
and enter a name. This will save the theme to an XML file in the
./scripts/presets/interface_theme/ subdirectory of one of the configuration directories.

Blender comes bundled with a small selection of themes.
This is an example of the theme Elsyiun.

File Preferences
The File Preferences tab allows you to configure auto-save preferences and set default file paths for blend-files,
rendered images, and more.

16

Bforartists Reference Manual - © Copyright - This page is under OCL license

File Paths
Locations for various external files can be set for the following options:
Fonts
Default location when searching for font files.
Textures
Default location when searching for image textures.
Render Output
Where rendered images/videos are saved.
Scripts
An additional location to search for Python scripts. See Scripts Path below.
Sounds
Default location when searching for sound files.
Temp
The location where temporary files are stored.
Render Cache
The location where cached render images are stored.
I18n Branches
The path to the /branches directory of your local svn-translation copy, to allow translating from the
UI.
Image Editor
The path to an external program to use for image editing.
Animation Player
The path to an external program to use for playback of rendered animations.
Hint
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If these folders do not exist, they will not be created automatically.

Scripts Path
By default Blender looks in several directories (OS dependant) for scripts. By setting a user script path in the
preferences an additional directory is looked in. This can be used to store certain scripts/templates/presets
independently of the currently used Blender Version.
Inside the specified folder specific folders have to be created to tell Blender what to look for where. This folder
structure has to mirror the structure of the scripts folder found in the installation directory of Blender:
•
•
•
•
•
•
•
•
•
•
•
•

scripts
add-ons
modules
presets
camera
cloth
interface_theme
operator
render
...
startup
templates Not all of the folders have to be present.

Auto Execution
Python scripts (including driver expressions) are not executed by default for security reasons.
Auto Run Python Scripts
You may choose to ignore these security issues and allow scripts to be executed automatically.
Excluded Paths
Blend files in these folders will not automatically run Python scripts. This can be used to define where
blend-files from untrusted sources are kept.

Save & Load
Relative Paths
By default, external files use a relative path.
Compress File
Compress blend-file when saving.
The option to Compress files will compact your files whenever Blender is saving them. Dense meshes,
large packed textures or lots of elements in your scene will result in a large blend being created.
This option may slow down Blender when you quit, or under normal operation when Blender is saving
your backup files. Using this option traces processor time for file-size.
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Load UI
Default setting is to load the Window layout (the Screens) of the saved file. This can be changed
individually when loading a file from the Open blend-file panel of the File Browser.

File extension filter.
Filter File Extensions
By activating this, the file dialog in the File Browser will only show appropriate files (i.e. blend-files
when loading a complete Blender setting). The selection of file types may be changed in the file dialog.
Hide Dot File/Data-blocks
Hide file which start with . on file browsers (in Linux and Apple systems, . files are hidden).
Hide Recent Locations
Hides the Recent panel of the File Browser which displays recently accessed folders.
Show Thumbnails
Displays a thumbnail of images and movies when using the File Browser.

Auto Save
Save Versions
Number of versions created for the same file (for backup).
This option tells Blender to keep the indicated number of saved versions of your file in your current
working directory when you manually save a file. These files will have the extension: .blend1,
.blend2, etc., with the number increasing to the number of versions you specify. Older files will be
named with a higher number. e.g. With the default setting of 2, you will have three versions of your file:
*.blend (your last save), *.blend1 (your second last save) and *.blend2 (your third last save).
Recent Files
Number of files displayed in File ‣ Open Recent.
Save Preview Images
Previews of images and materials in the File Browser are created on demand. To save these previews into
your blend-file, enable this option (at the cost of increasing the size of your blend-file).
Auto Save Temporary File
Enable Auto Save (create a temporary file).
Checking this box tells Blender to automatically save a backup copy of your work-in-progress to the
Temp directory (refer to the File tab in the User Preferences for its location).
The Auto Saved files are named using a random number and have a blend extension.
Timer
Time to wait between automatic saves.
This specifies the number of minutes between each Auto Save. The default value of the Blender
installation is 5 (5 minutes). The minimum is 1, and the Maximum is 60 (Save at every one hour).

19

Bforartists Reference Manual - © Copyright - This page is under OCL license

System Preferences
The System tab allows you to set resolution, scripting console preferences, sound, graphics cards, and
internationalization.

General
DPI
Value of the screen resolution which controls the size of Blender’s interface fonts and internal icons
shown. Useful for taking screen shots for book printing and use of high resolution monitors. During
typical usage, you may prefer to use zoom which is an available in many parts of Blender interface.
Virtual Pixel Mode
Allows you to select global scaling. While the DPI only scales the interface, this will scale line width,
vertex-size. This is intended for hi-dpi monitors.
Native
The normal pixel size.
Double
Double of the native pixel size.
Hint
This is auto-detected on OSX.
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Frame Server Port
TCP/IP port used in conjunction with the IP Address of the machine for frameserver rendering. Used
when working with distributed rendering. Avoid changing this port value unless it is conflicting with
already existing service ports used by your Operating System and/or softwares. Always consult your
operating system documentation and services or consult your system administrator before changing this
value.
Console Scrollback
The number of lines, buffered in memory of the console window. Useful for debugging purposes and
command line rendering.

Sound
Audio Device
Set the audio output device or no audio support:
None
No Audio support (no audio output, audio strips can be loaded normally)
SDL
Uses Simple Direct Media Layer API from libsdl.org to render sounds directly to the sound device
output. Very useful for sequencer strips editing.
OpenAL
Provides buffered sound rendering with 3D/spatial support. Used for 3D source support by Speaker
Objects and the Game Engine.
Sound options
Specific to SDL or OpenAL enabled
Channels
Set the audio channel count. Available options are: Stereo, 4 Channels , 5.1 Surround , 7.1 Surround
Mixing Buffer
Set the number of samples used by the audio mixing buffer. Available options are: 512 , 1024 , 2048,
4096 , 8192, 16384, and 32768
Sample Rate
Set the audio sample rate. Available options are: 44.1 Khz, 48 Khs, 96 Khz and 192Khz
Sample Format
Set the audio sample format. Available options are: 32 bit float, 8 bit Unsigned, 16 Bits Signed, 24 Bits
Signed, 32 Bits Signed, 32 Bits Float, and 64 Bits Float.

Screencast
These settings are used to control the frame-rate for recording a Screencast.
FPS
Frame-rate for screencast playback.
Wait Timer
Time in milliseconds between each frame recorded for screencast.

Compute Device
The Options here will set the compute device used by the Cycles render engine.
21
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None
When set to None or the only option is None: your CPU will be used as a computing device for Cycles
Render Engine
CUDA
If the system has a compatible Nvidia CUDA enabled graphics card you will be able to use it to render
with the Cycles render engine.
OpenCL
If the system has a compatible OpenCL device, it will show up has an option for rendering cycles.
Note
that this currently has limited support, see: Cycles Features page for more information.

OpenSubdiv Compute
The Options here will set the compute device used by OpenSubdiv for the Subdivision Surface Modifier.
None
Disables any OpenSubdiv compute devices, makes sure legacy subsurf method is used. Use this option
when OpenSubdiv causes any bugs or regressions.
CPU
Single threaded CPU implementation. It is mainly useful in cases when GPU compute is possible and
threaded CPU option causes artifacts (it is unlikely to happen, but still possible).
OpenMP
Multi-threaded CPU implementation. Use it for maximum performance in cases when GPU compute is
not available.
GLSL Transform Feedback
Uses GPU to perform calculations, has minimal requirements to video card and driver.
GLSL Compute
Uses GPU to perform calculations, supposed to be more efficient than Transform Feedback but also has
higher requirements to video card and driver.

OpenGL
Clip Alpha
Clip alpha below this threshold in the 3D View. Note that the default is set to a low value to prevent issues
on some GPU’s.
Mipmaps
Scale textures for 3D View using Mipmap filtering. This increases display quality, but uses more memory.
GPU MipMap Generation
Generate MipMaps on the GPU. Offloads the CPU Mimpap generation to the GPU.
16 Bit Float Textures
Enables the use of 16 Bit per component Texture Images (Floating point Images).
Selection
Selection method to use for selecting.
Automatic
Automatically choses the best setting depending on your OS, GPU, and drivers.
OpenGL Select
22
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Legacy OpenGL selection method for legacy hardware.
OpenGL Occlusion Queries
More optimized OpenGL selection method. Use this method if you are using an OpenSubdiv
Compute compute device.
Anisotropic Filtering
Sets the level of anisotropic filtering. This improves the quality of how textures are drawn at the cost of
performance. Available Options are: Off (No Filtering), 2x, 4x, 8x, and 16x.

Window Draw Method
Window Draw Method
Specifies the Window Draw Method used to display Blender Window(s).
Automatic
Automatically set based on graphics card and driver.
Triple Buffer
Use a third buffer for minimal redraws at the cost of more memory. If you have a capable GPU, this
is the best and faster method of redraw.
Overlap
Redraw all overlapping regions. Minimal memory usage, but more redraws. Recommended for
some graphics cards and drivers combinations.
Overlap Flip
Redraw all overlapping regions. Minimal memory usage, but more redraws (for graphics drivers
that do flipping). Recommended for some graphic cards and drivers combinations.
Full
Do a full redraw each time. Only use for reference, or when all else fails. Useful for certain cards
with bad to no OpenGL acceleration at all.
Multi-Sampling
This enables FSAA for smoother drawing, at the expense of some performance.
Note
This is known to cause selection issues on some configurations

Region Overlap
This checkbox will enable Blender to draw regions overlapping the 3D View. It means that the Object
Tools and Transform Properties regions, which are opened by using the shortcuts T and N will be drawn
overlapping the 3D View editor.
If you have a capable graphics card and drivers with Triple Buffer support, clicking the checkbox will
enable the overlapping regions to be drawn using the Triple Buffer method, which will also enable them
to be drawn using Alpha, showing the 3D View contents trough the Object Tools and Transform
Properties regions.
Text Draw Options
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Enable interface text anti-aliasing. When disabled, texts are drawn using text straight render (Filling only
absolute Pixels).

Textures
Limit Size
Limit the maximum resolution for pictures used in textured display to save memory. The limit options are
specified in a square of pixels, (e.g.: the option 256 means a texture of 256×256 pixels) This is useful for
game engineers, whereas the texture limit matches paging blocks of the textures in the target graphic card
memory. Available Options are: Off (No limit), 128, 256, 512, 1024, 2048, 4096, and 8192.
Time Out
Time since last access of a GL texture in seconds, after which it is freed. Set to 0 to keep textures
allocated. Minimum: 0, Maximum: 3600.
Collection Rate
Number of seconds between each run of the GL texture garbage collector. Minimum: 0, Maximum: 3600.
Image Draw Method
Method to draw images as the following options are supported:
2D Texture
Uses CPU for display transform and draws images as a 2D texture.
GLSL
Fastest method using GLSL for display transform and draws images as a 2D texture.
Draw Pixels
Uses CPU for display transform and draws images as a 2D texture.

Sequencer/Clip Editor
Memory Cache Limit
Upper limit of the sequencer’s memory cache (megabytes). For optimum clip editor and sequencer
performance, high values are recommended.

Solid OpenGL lights
Solid OpenGL Lights are used to light the 3D View, mostly during Solid view. Lighting is constant and position
“world” based. There are three virtual light sources, also called OpenGL auxiliary lamps, used to illuminate 3D
View scenes, which will not display in renders.
The Lamp Icons allows the user to enable or disable OpenGL Lamps. At least one of the three auxiliary
OpenGL Lamps must remain enabled for the 3D View. The lamps are equal, their difference is their positioning
and colors. You can control the direction of the lamps, as well as their diffuse and specular colors. Available
Options are:
Direction
Clicking with LMB in the sphere and dragging the mouse cursor let us the user change the direction of the
lamp by rotating the sphere. The direction of the lamp will be the same as shown at the sphere surface.
Diffuse
This is the constant color of the lamp. Clicking on the color widget, opens the color picker pop-up and
allows the user to change colors using the color picker.
Specular
This is the highlight color of the lamp Clicking on the color widget, opens the color picker pop-up and
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allows the user to change colors using the color picker.

Color Picker Type
Choose which type of color space you prefer. It will show when clicking LMB on any color field.
See the different color picker types at the Extended Controls page.

Custom Weight Paint Range
Mesh skin weighting is used to control how much a bone deforms the mesh of a character. To visualize and
paint these weights, Blender uses a color ramp (from blue to green, and from yellow to red). Enabling the
checkbox will enable an alternate map using a ramp starting with an empty range. Now you can create your
custom map using the common color ramp options. For detailed information about how to use color ramps, see:
to the Extended Controls page.

Internationalization
Blender supports a wide range of languages, enabling this check box will enable Blender to support
International Fonts. International fonts can be loaded for the User Interface and used instead of Blender default
bundled font.
This will also enable options for translating the User Interface through a list of languages and Tips for Blender
tools which appear whenever the user hovers a mouse over Blender tools.
Blender supports I18N for internationalization. For more Information on how to load International fonts, see:
Editing Texts page.
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