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User Preferences
This chapter explains how to change Bforartists’s default configuration with the User Preferences editor.
The Bforartists User Preferences editor contains settings to to control how Bforartists behaves.

Open User Preferences
To open a Bforartists User Preferences editor go to File ‣ User Preferences.

Configure
Now that you have opened the User Preferences editor, you can configure Bforartists to your liking. At the top
of the window, the available options are grouped into seven tabs:
Interface
Change how UI elements are displayed and how they react.
Editing
Control how several tools will interact with your input.
Input
Customize how Bforartists reacts to the mouse and keyboard as well as define your own keymap.
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Add-ons
Manage Bforartists’s Add-ons, allowing you to access features not built-in as well as install new features.
Themes
Customize interface appearance and colors.
File
Configure auto-save preferences and set default file paths for .blend files, rendered images, and more.
System
Set resolution, scripting console preferences, sound, graphics cards, and internationalization.

Save the new preferences
Once you have set your preferences, you will need to manually save them, otherwise the new configuration will
be lost after a restart. Bforartists saves its preferences to userpref.blend in your user folder (see next section,
“Load Factory Settings”, for details).
In the User Preferences window, click on the Save User Settings button in the bottom left. This will save all of
the new preferences.

Load Factory Settings
Go to File ‣ Load Factory Settings then save the preferences via the User Preferences editor.
Hint
It can be valuable to make a backup of your preferences the event that you lose your configuration.
See the directory layout section to see where your preferences are stored.

Interface
Interface configuration lets you change how UI elements are displayed and how they react.
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Display
Tooltips
When enabled, a tooltip will appear when your mouse pointer is over a control. This tip explains the
function of what’s under the pointer, gives the associated hotkey (if any) and the Python function that
refers to it.
Object Info
Display the active Object name and frame number at the bottom left of the 3D view.
Large Cursors
Use large mouse cursors when available.
View Name
Display the name and type of the current view in the top left corner of the 3D window. For example: User
Persp or Top Ortho.
Playback FPS
Show the frames per second screen refresh rate while an animation is played back. It appears in the
viewport corner, displaying red if the frame rate set can’t be reached.
Global Scene
Forces the current scene to be displayed in all screens (a project can consist of more than one scene).
Object Origin Size
Diameter of 3D Object centers in the view port (value in pixels from 4 to 10).
Display Mini Axis
Show the mini axis at the bottom left of the viewport.
Size
Size of the mini axis.
Brightness
Adjust brightness of the mini axis.

View manipulation
Cursor Depth
4
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Use the depth under the mouse when placing the cursor.
Auto Depth
Use the depth under the mouse to improve view pan/rotate/zoom functionality.
Zoom to Mouse Position
When enabled, the mouse pointer position becomes the focus point of zooming instead of the 2D window
center. Helpful to avoid panning if you are frequently zooming in and out.
Rotate Around Selection
The selected object becomes the rotation center of the viewport. When there is no selection the last
selection will be used.
Hint
This may seem ideal behavior, however it can become problematic with larger objects such as a terrainmesh, where the center isn’t necessarily your point of interest.
Global Pivot
Lock the same rotation/scaling pivot in all 3D views.
Auto Perspective
Automatically to perspective Top/Side/Front view after using User Orthographic. When disabled,
Top/Side/Front views will retain Orthographic or Perspective view (whichever was active at the time of
switching to that view).
Smooth View
Length of time the animation takes when changing the view with the numpad (Top/Side/Front/Camera...).
Reduce to zero to remove the animation.
Rotation Angle
Rotation step size in degrees, when Numpad4, Numpad6, Numpad8, or Numpad2 are used to rotate the
3D view.

2D Viewports
Minimum Grid Spacing
The minimum number of pixels between grid lines in a 2D (i.e. top orthographic) viewport.
TimeCode Style
Format of Time Codes displayed when not displaying timing in terms of frames. The format uses ‘+’ as
separator for sub-second frame numbers, with left and right truncation of the timecode as necessary.

Manipulator
Permits configuration of the 3D transform manipulator which is used to drag, rotate and resize objects (Size,
Handle size).

Menus
Open on Mouse Over
Select this to have the menu open by placing the mouse pointer over the entry instead of clicking on it.
Menu Open Delay
Time for the menu to open.
5
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Top Level
Time delay in 1/10 second before a menu opens (Open on Mouse Over needs to be enabled).
Sub Level
Same as above for sub menus (for example: File ‣ Open Recent).

Editing
These preferences control how several tools will interact with your input.

Link Materials To

Example for a Mesh

To understand this option properly, you need to understand how Bforartists works with Objects. Almost
everything in Bforartists is organized in a hierarchy of data-blocks. A data-block can be thought of as containers
for certain pieces of information. For example, the Object data-block contains information about the Object’s
location while the Object Data (ObData) data-block contains information about the mesh.
A material may be linked in two different ways:

A material linked to ObData (left) and Object (right).

ObData
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Any created material will be created as part of the ObData data-block.
Object
Any created material will be created as part of the Object data-block.
Read more about Bforartists’s Data System

New objects
Enter Edit Mode
If selected, Edit Mode is automatically activated when you create a new object.
Align To
World
New objects align with world coordinates.
View
New object align with view coordinates.

Undo
Global Undo
This enables Bforartists to save actions done when you are not in Edit Mode. For example, duplicating
Objects, changing panel settings or switching between modes.
Warning
While disabling this option does save memory, it stops the redo panel from functioning, also preventing
tool options from being changed in some cases.
For typical usage, its best to keep this enabled.

Step
Number of Undo steps available.
Memory Limit
Maximum memory usage in Mb (0 is unlimited).
Read more about Undo and Redo options

Grease Pencil
Grease Pencil permits you to draw in the 3D viewport with a pencil-like tool.
Manhattan Distance
The minimum number of pixels the mouse has to move horizontally or vertically before the movement is
recorded.
Euclidian Distance
The minimum distance that mouse has to travel before movement is recorded.
Eraser Radius
The size of the eraser used with the grease pencil.
Smooth Stroke
Smooths the pencil stroke after it’s finished.
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Playback
Allow Negative Frame
If set, negative framenumbers might be used.

Keyframing
In many situations, animation is controlled by keyframes. The state of a value (e.g. location) is recorded in a
keyframe and the animation between two keyframes is interpolated by Bforartists.
Visual Keying
Use Visual keying automatically for constrained objects.
Only Insert Needed
When enabled, new keyframes will be created only when needed.
Auto Keyframing
Automatic keyframe insertion for Objects and Bones. Auto Keyframe is not enabled by default.
Only Insert Available
Automatic keyframe insertion in available curves.
New F-Curve Defaults
Interpolation
This controls how the state between two keyframes is computed. Default interpolation for new
keyframes is Bezier which provides smooth acceleration and de-acceleration whereas Linear or
Constant is more abrupt.
XYZ to RGB
Color for X, Y or Z animation curves (location, scale or rotation) are the same as the color for the
X, Y and Z axis.

Transform
Release confirm
Dragging LMB on an object will move it. To confirm this (and other) transforms, a LMB is necessary by
default. When this option is activated, the release of LMB acts as confirmation of the transform.

Sculpt Overlay Color
This color selector allows the user to define a color to be used in the inner part of the brushes circle when in
sculpt mode, and it is placed as an overlay to the brush, representing the focal point of the brush influence. The
overlay color is visible only when the overlay visibility is selected (clicking at the eye to set its visibility), and
the transparency of the overlay is controled by the alpha slider located at the brush selector panel, located at the
top of the tool shelf, when in sculpt mode.

Duplicate Data
The ‘Duplicate Data’ check-boxes define what data is copied with a duplicated Object and what data remains
linked. Any boxes that are checked will have their data copied along with the duplication of the Object. Any
boxes that are not checked will instead have their data linked from the source Object that was duplicated.
For example, if you have Mesh checked, then a full copy of the mesh data is created with the new Object, and
8
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each mesh will behave independently of the duplicate. If you leave the mesh box unchecked then when you
change the mesh of one object, the change will be mirrored in the duplicate Object.
The same rules apply to each of the check-boxes in the ‘Duplicate Data’ list.

Input
In the Input preferences, you can customize how Bforartists reacts to the mouse and keyboard as well as define
your own keymap.

Managing presets
Bforartists lets you define multiple Preset input configurations. Instead of deleting the default keymap to create
yours, you can just add new Presets for both the mouse and keyboard. Mouse options can be found on the left
hand side of the window and keyboard options to the right in the above picture.

Adding and deleting presets

Before changing anything in the default configuration, click on the “plus” symbol shown in the picture to add a
new Preset. Bforartists will ask you to name your new preset after which you can select the Preset from the list
to edit it. If you want to delete your Preset, select it from the list and then click the “minus” symbol.

Selecting presets
You can change the preset you are using by doing one of the following:
9
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• Selecting the configuration from the Interaction menu of the splash screen at startup or by selecting
Help ‣ Splash Screen.
• Selecting the configuration from the User Preferences Input window.
Note
Note that either of the above options will only change the preset for the current file. If you select File ‣ New
or File ‣ Open, the default preset will be re-loaded.

Setting presets to default

Once you’ve configured your mouse and keyboard Presets, you can make this the default configuration by:
• Opening the User Preferences Input editor and select your presets from the preset list or,
• Selecting your preset configuration from the splash screen.
• Saving your configuration using the Save As Default option from a User Preferences window or by
pressing Ctrl-U.

Export/Import key configuration
In some cases, you may need to save your configuration in an external file (e.g. if you need to install a new
system or share your keymap configuration with the community). Simply LMB Export Key Configuration on the
Input tab header and a file browser will open so that you can choose where to store the configuration. The
Import Key Configuration button installs a keymap configuration that is on your computer but not in
Bforartists.

Mouse
Emulate 3 Button Mouse
Bforartists can be configured to work with pointing devices which don’t have a middle-mouse button
(such as a two-button mouse, Apple single-button mouse, or laptop touch-pad). The functionality of the 3
mouse buttons will then be be emulated with key/mouse-button combinations as shown in the table
below.
Shortcuts for supported mouse hardware

3-button Mouse
LMB
MMB
RMB

2-button Mouse
LMB
Alt-LMB
RMB
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Mouse/Keyboard combinations refrenced in this manual can be expressed with the combinations shown
in the table. For Example.
• MMB drag becomes Alt-LMB drag.
• Shift-Alt-RMB becomes Shift-Alt-Cmd-LMB on a single-button mouse.
Continuous Grab
This feature is used to prevent the problem where an action such as grabbing or panning a view, is limited
by your screen bounds.
This is done by warping the mouse within the view.
Note
Cursor warping is only supported by relative input devices (mouse, trackball, trackpad).
Graphics tablets however, typically use absolute positioning, this feature is disabled when a tablet is
being used
This is detected for each action, so the presence of a tablet wont disable continuous-grab for mouse
cursor input.

Drag Threshold
The number of pixels that a User Interface element has to be moved before it is recognized by Bforartists.
Select with
You can choose which button is used for selection (the other one is used to place the 3D cursor).
Double Click
The time for a double click (in ms).
Note
The Mouse emulate option is only available if Select With is set to Right.

Graphic Tablets
Graphic tablets can be used to provide a more traditional method of controlling the mouse cursor using a pen.
This can help to provide a more familiar experience for artists who are used to painting and drawing with
similar tools, as well as provide additional controls such as pressure sensitivity.
Note
If you are using a graphic tablet instead of a mouse and pressure sensitivity doesn’t work properly, try to place
the mouse pointer in the Bforartists window and then unplug/replug your graphic tablet. This might help.

Numpad Emulation
The Numpad keys are used quite often in Bforartists and are not the same keys as the regular number keys. If
you have a keyboard without a Numpad (e.g. on a laptop), you can tell Bforartists to treat the standard number
11
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keys as Numpad keys. Just check Emulate Numpad.

View Manipulation
Orbit Style
Select how Bforartists works when you rotate the 3D view by default when holding MMB.
Turntable
Rotates the view keeping the horizon horizontal.
This behaves like a potters wheel or record player where you have two axes of rotation available,
and the world seems to have a better definition of what is “Up” and “Down” in it.
The drawback to using the Turntable style is that you lose some flexibility when working with your
objects. However, you gain the sense of “Up” and “Down” which can help if you are feeling
disoriented.
Orbit
Is less restrictive, allowing any orientation.
Zoom Style
Choose your preferred style of zooming in and out with Ctrl-MMB
Scale
Scale zooming depends on where you first click in the view. To zoom out, hold Ctrl-MMB while
dragging from the edge of the screen towards the center. To zoom in, hold Ctrl-MMB while
dragging from the center of the screen towards the edge.
Continue
The Continue zooming option allows you to control the speed (and not the value) of zooming by
moving away from the initial click-point with Ctrl-MMB. Moving up from the initial click-point or
to the right will zoom out, moving down or to the left will zoom in. The further away you move, the
faster the zoom movement will be. The directions can be altered by the Vertical and Horizontal
radio buttons and the Invert Zoom Direction option.
Dolly
Dolly zooming works similarly to Continue zooming except that zoom speed is constant.
Vertical
Moving up zooms out and moving down zooms in.
Horizontal
Moving left zooms in and moving right zooms out.
Invert Zoom Direction
Inverts the Zoom direction for Dolly and Continue zooming.
Invert Wheel Zoom Direction
Inverts the direction of the mouse wheel zoom.
NDOF device
Set the sensitivity of a 3D mouse.
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Keymap editor

The Keymap editor lets you change the default Hotkeys. You can change keymaps for each window.
• Select the keymap you want to change and click on the white arrows to open up the keymap tree.
• Select which Input will control the function
• Keyboard: Only hotkey or combo hotkey (E or Shift-E).
• Mouse: Left/middle/right click. Can be combined with Alt, Shift, Ctrl, Cmd.
• Tweak: Click and drag. Can also be combined with the 4 previous keys.
• Text input: Use this function by entering a text
• Timer: Used to control actions based on a time period. e.g. By default, Animation Step uses
Timer 0, Smooth view uses Timer 1.
• Change hotkeys as you want. Just click on the shortcut input and enter the new shortcut.
If you want to restore the default settings for a keymap, just click on the Restore button at the top right of this
keymap.

Add-ons
The Add-ons tab lets you manage secondary options which are not enabled in Bforartists by default. New
features may be added with Install Add-ons. There will be a growing number of such Add-ons, generated by the
Bforartists-community so look out for that one feature you were missing (or maybe simply create it yourself).
See the Add-ons Page for more on using Add-ons.
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Themes
The Themes tab allows you to customize interface appearance and colors.

The colors for each editor can be set separately - simply select the editor you wish to change in the multi-choice
list at the left, and adjust colors as required. Notice that changes appear in real-time on your screen. In addition,
14
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details such as the dot size in the 3D View or the Graph Editor can also be changed.
Themes use Bforartists’s preset system. To save a theme, click the + button next to the preset selection dropdown and enter a name. This will save the theme to an XML file in the
./scripts/presets/interface_theme/ subdirectory of one of the configuration directories.

Bforartists comes bundled with a small selection of themes.

This is an example of the theme Elsyiun.

File Preferences
The File Preferences tab allows you to configure auto-save preferences and set default file paths for .blend files,
rendered images, and more.
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File Paths
Locations for various external files can be set for the following options:
Fonts
Default location when searching for font files.
Textures
Default location when searching for image textures.
Render Output
Where rendered images/videos are saved.
Scripts
An additional location to search for Python scripts. See Scripts Path below.
Sounds
Default location when searching for sound files.
Temp
The location where temporary files are stored.
Render Cache
The location where cached render images are stored.
I18n Branches
The path to the /branches directory of your local svn-translation copy, to allow translating from the
UI.
Image Editor
The path to an external program to use for image editing.
Animation Player
The path to an external program to use for playback of rendered animations.

Note
If these folders do not exist, they will not be created automatically.
16
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Scripts Path
By default Bforartists looks in several directories (OS dependant) for scripts. By setting a user script path in the
preferences an additional directory is looked in. This can be used to store certain scripts/templates/presets
independently of the currently used Bforartists Version.
Inside the specified folder specific folders have to be created to tell Bforartists what to look for where. This
folder structure has to mirror the structure of the scripts folder found in the installation directory of Bforartists:
•
•
•
•
•
•
•
•
•
•
•
•

scripts
add-ons
modules
presets
camera
cloth
interface_theme
operator
render
...
startup
templates Not all of the folders have to be present.

Auto Execution
Python scripts (including driver expressions) are not executed by default for security reasons.
Auto Run Python Scripts
You may choose to ignore these security issues and allow scripts to be executed automatically.
Excluded Paths
Blend files in these folders will not automatically run Python scripts. This can be used to define where
blend files from untrusted sources are kept.
See also
Scripting & Security

Save & Load
Relative Paths
By default, external files use a relative path.
Compress File
Compress .blend file when saving.
Load UI
Default setting is to load the Window layout (the Screens) of the saved file. This can be changed
individually when loading a file from the Open Bforartists File panel of the File Browser window.
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File extension filter

Filter File Extensions
By activating this, file dialog windows will only show appropriate files (i.e. .blend files when loading a
complete Bforartists setting). The selection of file types may be changed in the file dialog window.
Hide Dot File/Data-blocks
Hide file which start with . on file browsers (in Linux and Apple systems, . files are hidden).
Hide Recent Locations
Hides the Recent panel of the File Browser window which displays recently accessed folders.
Show Thumbnails
Displays a thumbnail of images and movies when using the File Browser.

Auto Save
Save Versions
Number of versions created for the same file (for backup).
Recent Files
Number of files displayed in File ‣ Open Recent.
Save Preview Images
Previews of images and materials in the File Browser window are created on demand. To save these
previews into your .blend file, enable this option (at the cost of increasing the size of your .blend
file).
Auto Save Temporary File
Enable Auto Save (create a temporary file).
Timer
Time to wait between automatic saves.

System Preferences
The System tab allows you to set resolution, scripting console preferences, sound, graphics cards, and
internationalization.
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General
DPI
Value of the screen resolution which controls the size of Bforartists’s interface fonts and internal icons
shown. Useful for taking screen shots for book printing and use of high resolution monitors. During
typical usage, you may prefer to use zoom which is a available in many parts of Bforartists interface.
Virtual Pixel Mode
Allows you to select global scaling. While the DPI only scales the interface, this will scale line width,
vertex-size.
This is intended for hi-dpi monitors.
Note
This is auto-detected on OSX.

Frame Server Port
TCP/IP port used in conjunction with the IP Address of the machine for frameserver rendering. Used
when working with distributed rendering. Avoid changing this port value unless it is conflicting with
already existing service ports used by your Operating System and/or softwares. Always consult your
operating system documentation and services or consult your system administrator before changing this
value.
Console Scrollback
The number of lines, buffered in memory of the console window. Useful for debugging purposes and
command line rendering.
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Sound
Sound
Set the audio output device or no audio support:
None
No Audio support (no audio output, audio strips can be loaded normally)
SDL
Uses Simple Direct Media Layer API from libsdl.org to render sounds directly to the sound device
output. Very useful for sequencer strips editing.
OpenAL
This API provides buffered sound rendering with 3D/spatial support.
Used for 3D source support by Speaker Objects and the Game Engine.
‘Specific sound options’ (With SDL or OpenAL enabled)
Channels
Set the audio channel count. Available options are: Stereo (Default) , 4 Channels , 5.1
Surround , 7.1 Surround
Mixing Buffer
Set the number of samples used by the audio mixing buffer. Available options are:
512 , 1024 , 2048 (Default), 4096 , 8192, 16384, and 32768
Sample Rate
Set the audio sample rate. Available options are: 44.1 Khz (Default), 48 Khs , 96 Khz and
192Khz
Sample Format
Set the audio sample format. Available options are: 32 bit float (Default), 8 bit Unsigned , 16
Bits Signed , 24 Bits Signed , 32 Bits Signed , 32 Bits Float and 64 Bits Float

Screencast
TODO

Compute Device
The Options here will set the compute device used by the Cycles render engine.
None
When set to None or the only option is None: your CPU will be used as a computing device for Cycles
Render Engine
CUDA
If the system has a compatible CUDA enabled graphics card and appropriate device drivers installed.
20
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When one or both of the options are available, the user will be able to choose whether to use CPU or
other computing device for Cycles Rendering.
OpenCL
Note that this currently has limited support unsupported, see: Cycles Render engine page

OpenSubdiv Compute
The Options here will set the compute device used by OpenSubdiv for the Subdivision Surface Modifier.
None
Disables any OpenSubdiv compute devices, makes sure legacy subsurf code from Bforartists is used. Use
this option when OpenSubdiv causes any bugs or regressions.
CPU
Single threaded CPU implementation. It is mainly useful in cases when GPU compute is possible and
threaded CPU option causes artifacts (it is unlikely to happen, but still possible).
OpenMP
Multi-threaded CPU implementation. It is similar to threading model of old subsurf code. Use it for
maximum performance in cases when GPU compute is not available.
GLSL Transform Feedback
Uses GPU to perform calculations, has minimal requirements to video card and driver.
GLSL Compute
Uses GPU to perform calculations, supposed to be more efficient than Transform Feedback but also has
higher requirements to video card and driver.

Open GL
Clip Alpha
Clip alpha below this threshold in the 3D viewport. Minimum: 0.000 (No Clip) , Maximum: 1.000 ,
Default 0.000 (No Clip)
Mipmaps
Scale textures for 3D view using mipmap filtering. This increases display quality, but uses more memory.
GPU MipMap Generation
Generate MipMaps on the GPU. Offloads the CPU Mimpap generation to the GPU.
16 Bit Float Textures
Enables the use of 16 Bit per component Texture Images (Floating point Images).
Anisotropic Filtering
Set the level of anisotropic filtering. Available Options are: Off’’ (No Filtering) , 2x (Default) , 4x , 8x ,
16x

Window Draw Method
Window Draw Method
Specifies the Window Draw Method used to display Bforartists Window(s).
Automatic (Default)
Automatically set based on graphics card and driver.
Triple Buffer
Use a third buffer for minimal redraws at the cost of more memory. If you have a capable GPU, this
is the best and faster method of redraw.
Overlap
21
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Redraw all overlapping regions. Minimal memory usage, but more redraws. Recommended for
some graphics cards and drivers combinations.
Overlap Flip
Redraw all overlapping regions. Minimal memory usage, but more redraws (for graphics drivers
that do flipping). Recommended for some graphic cards and drivers combinations.
Full
Do a full redraw each time. Only use for reference, or when all else fails. Useful for certain cards
with bad to no OpenGL acceleration at all.
Multi-Sampling
This enables FSAA for smooth drawing, at the expense of some performance.
Note
This is known to cause selection issues on some configurations, see: Invalid Selection.

Region Overlap
This checkbox will enable Bforartists to draw regions overlapping the 3D Window. It means that the
Object Tools and Transform Properties Tab, which are opened by using the shortcuts T and N will be
drawn overlapping the 3D View Window.
If you have a capable graphics card and drivers with Triple Buffer support, clicking the checkbox will
enable the overlapping regions to be drawn using the Triple Buffer method, which will also enable them
to be drawn using Alpha, showing the 3D View contents trough the Object Tools and Transform
Properties Tab.

Text Draw Options
Text Draw Options
Enable interface text anti-aliasing. When disabled, texts are drawn using text straight render (Filling only
absolute Pixels). Default: Enabled.

Textures
Limit Size
Limit the maximum resolution for pictures used in textured display to save memory. The limit options are
specified in a square of pixels, (e.g.: the option 256 means a texture of 256x256 pixels) This is useful for
game engineers, whereas the texture limit matches paging blocks of the textures in the target graphic card
memory. Available Options are: Off (No limit - Default) , 128, 256, 512, 1024, 2048, 4096, 8192.
Time Out
Time since last access of a GL texture in seconds, after which it is freed. Set to 0 to keep textures
allocated. Minimum: 0 , Maximum: 3600 , Default: 120
Collection Rate
Number of seconds between each run of the GL texture garbage collector. Minimum: 0 , Maximum:
3600 , Default: 120
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Sequencer/Clip Editor
Memory Cache Limit
Upper limit of the sequencer’s memory cache (megabytes). For optimum clip editor and sequencer
performance, high values are recommended. Minimum: 0 (No cache) , Maximum: 1024 (1 Gigabyte),
Default: 128

Solid OpenGL lights
Solid OpenGL Lights are used to light the 3D Window, mostly during Solid view. Lighting is constant and
position “world” based. There are three virtual light sources, also called OpenGL auxiliary lamps, used to
illuminate 3D View scenes, which will not display in renders.
The Lamp Icons allows the user to enable or disable OpenGL Lamps. At least one of the three auxiliary
OpenGL Lamps must remain enabled for the 3D View. The lamps are equal, their difference is their positioning
and colors. You can control the direction of the lamps, as well as their diffuse and specular colors. Available
Options are:
Direction
Clicking with LMB in the sphere and dragging the mouse cursor let’s the user change the direction of the
lamp by rotating the sphere. The direction of the lamp will be the same as shown at the sphere surface.
Diffuse
This is the constant color of the lamp. Clicking on the color widget, opens the color picker mini window
and allows the user to change colors using the color picker.
Specular
This is the highlight color of the lamp Clicking on the color widget, opens the color picker mini window
and allows the user to change colors using the color picker.

Color Picker Type
Choose which type of color dialog you prefer - it will show when clicking LMB on any color field.
See the different color picker types at the Extended Controls page.

Custom Weight Paint Range
Mesh skin weighting is used to control how much a bone deforms the mesh of a character. To visualize and
paint these weights, Bforartists uses a color ramp (from blue to green, and from yellow to red). Enabling the
checkbox will enable an alternate map using a ramp starting with an empty range. Now you can create your
custom map using the common color ramp options. For detailed information about how to use color ramps, see:
to the Extended Controls page.

Internationalization
Bforartists supports a wide range of languages, enabling this check box will enable Bforartists to support
International Fonts. International fonts can be loaded for the User Interface and used instead of Bforartists
default bundled font.
This will also enable options for translating the User Interface through a list of languages and Tips for
Bforartists tools which appears whenever the user hovers a mouse over Bforartists tools.
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Bforartists supports I18N for internationalization. For more Information on how to load International fonts, see:
Editing Texts page.

Startup File
Reference
Mode: All modes
Menu: File ‣ Save Startup File
When you start Bforartists or start a new project with the menu entry File ‣ New, a new scene is created from
the default scene included with Bforartists.
This default scene can instead be your own customized setup.
To change the default scene, make all of the desired changes to the current scene or current file and File ‣
Save Startup File.

Restoring to Factory Settings
Reference
Mode: All modes
Menu: File ‣ Load factory Settings
To restore the startup file to the factory settings, open File ‣ Load Factory Settings. This will restore the
Startup File and User Preferences back to the original factory settings. After this you can save the startup file to
overwrite any customizations permanently.
Note
User Preferences Window
For more information about the Editor Window for User Preferences or how to clean your preferences
manually, see User Preferences
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